博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
poj2312--Battle City(Bfs)
阅读量:5998 次
发布时间:2019-06-20

本文共 2866 字,大约阅读时间需要 9 分钟。

Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7712 Accepted: 2582

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 
Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4 
YBEB 
EERE 
SSTE 
0 0

Sample Output

8

Source

,鲁小石

优先队列, 没啥了。。。。。。。。

#include <queue>
#include <cstdio>
#include <iostream>
using 
namespace std;
char map[
300][
300]; 
int ac[
4][
2] = {
0
1
0, -
1, -
1
0
1
0};
int n, m;
struct Maze
{
    
int x, y, step;
    friend 
bool 
operator < (Maze x, Maze y)
    {
        
return x.step > y.step;        
    } 
}r, s, t;
int Bfs(
int a, 
int b)
{
    r.x = a; r.y = b; r.step = 
0;
    map[a][b] = 
'
S
';
    priority_queue<Maze> Q;
    Q.push(r);
    
while(!Q.empty())
    {
        s = Q.top(); Q.pop();
        
for(
int i = 
0; i < 
4; i++)
        {
            t.x = s.x + ac[i][
0];
            t.y = s.y + ac[i][
1];
            t.step = s.step + 
1;
            
if(t.x >= 
0 && t.x < n && t.y >= 
0 && t.y < m && map[t.x][t.y] != 
'
R
' && map[t.x][t.y] != 
'
S
')
            {
                
if(map[t.x][t.y] == 
'
T
')
                    
return t.step;
                
if(map[t.x][t.y] == 
'
B
')
                {
                    t.step += 
1;
                }
                map[t.x][t.y] = 
'
S
';
                Q.push(t);    
            } 
        } 
    }
    
return -
1
int main() 
{
    
while(~scanf(
"
%d %d
", &n, &m), n+m)
    {
        
int x, y;
        
for(
int i = 
0; i < n; i++)
        {
            scanf(
"
%s
", map[i]);
            
for(
int j = 
0; j < m; j++)
            {
                
if(map[i][j] == 
'
Y
')
                {
                    x = i;
                    y = j;
                }
            }
        }
        printf(
"
%d\n
", Bfs(x, y));
    }
    
return 
0;}

 

转载于:https://www.cnblogs.com/soTired/p/4779133.html

你可能感兴趣的文章
预约系统(六) 管理页面首页
查看>>
列表、元组、字符串方法,字符串的编码
查看>>
Java8 新特性 Streams map() 示例
查看>>
js页面刷新的方法location.reload()
查看>>
C++标准转换运算符const_cast
查看>>
设计模式-适配器模式
查看>>
前端面试题(HTML和css部分)
查看>>
不容易系列之(4)——考新郎
查看>>
J2EE第八周
查看>>
css盒子3
查看>>
JSP中的静态包含和动态包含的区别
查看>>
聚类分析之层次划分(Hierarchical、Birch)
查看>>
Linux 查看网络信息,路由信息和DNS信息的命令
查看>>
毕设今日总结(三)
查看>>
Node 实现 AES 加密,结果输出为“byte”。
查看>>
常见js特效的思路
查看>>
javascript 对象
查看>>
Systick时钟定时
查看>>
angular之service、factory预provider区别
查看>>
Kettle_使用Pan.bat执行转换、Kitchen.bat执行作业
查看>>